DEF empty warning, but DEF tank is FULL.. Anyone have this issue?

NEVADADSL

Member
Aug 17, 2021
53
32
I just got the DEF warning that the tank was empty and I had 500 miles to reduced speed of 65 MPH. Plus the warning light on the dash. My DEF tank is full. Anyone have this issue that can shed some light? Hate to take it to the local dealer as they suck and take forever.
Edit Called dealer and was told probably just a glitch and should clear itself. We'll see. Just in case have an appt in 2 weeks...SMH
 
Last edited:
UPDATE: It seems that the dealer was correct as the glitch seems to have gone away on its own. Still, when one pays $60K plus for a new vehicle I would like to think the designers and engineers know what the hell they are doing...
 
Rolling computers. Don't think that I would like windowz operating system controlling my truck either. Android has been stable on my phones, though.
 
If it happens again and again, I would take it in and get it fixed. If it repeats, it's more than a glitch, especially if it doesn't clear itself in enough time and goes into full limp mode. Just like the crank no start, it's annoying.
 
Every time I tow I get this message. I just returned from a trip towing my toyhauler (7,200lbs).
1,524 miles 5.5gal of DEF. I got the first low def message at 500 mi. added 2gal and it over filled. Next morning no fault level read full. Next 500mi. Same thing. Next 500mi. message says 0 Def, range to reduced speed 600mi. After driving for 10 minutes with this message it cleared. No issues after that.
 
Every time I tow I get this message. I just returned from a trip towing my toyhauler (7,200lbs).
1,524 miles 5.5gal of DEF. I got the first low def message at 500 mi. added 2gal and it over filled. Next morning no fault level read full. Next 500mi. Same thing. Next 500mi. message says 0 Def, range to reduced speed 600mi. After driving for 10 minutes with this message it cleared. No issues after that.

Have you took it in about this yet? Seems like the gauge isn't reading correctly.
 
Every time I tow I get this message. I just returned from a trip towing my toyhauler (7,200lbs).
1,524 miles 5.5gal of DEF. I got the first low def message at 500 mi. added 2gal and it over filled. Next morning no fault level read full. Next 500mi. Same thing. Next 500mi. message says 0 Def, range to reduced speed 600mi. After driving for 10 minutes with this message it cleared. No issues after that.
Correction, I used 7.5 gal. DEF. I took it to my dealer last year for this problem, they replaced a sensor that they said had shorted out . Under warranty.
 
UPDATE: It seems that the dealer was correct as the glitch seems to have gone away on its own. Still, when one pays $60K plus for a new vehicle I would like to think the designers and engineers know what the hell they are doing...
I think I have just the opposite problem, my def Guage doesn't move took it to the dealer Guage was reading 3/4 dealer said it was at a 1/2 and just needed a flash update.
They filled the tank and 2000 miles later am still showing full and to top it off warranty expires in a month
 
I think I have just the opposite problem, my def Guage doesn't move took it to the dealer Guage was reading 3/4 dealer said it was at a 1/2 and just needed a flash update.
They filled the tank and 2000 miles later am still showing full and to top it off warranty expires in a month
When was the flash done?

GM just came out with this. Did you have this one done?...
 

Attachments

  • DEF level update 2023.pdf
    150.1 KB · Views: 5
You have 8 year or 80k miles, whichever comes first for warranty.
 
When was the flash done?

GM just came out with this. Did you have this one done?...
Yes pretty sure that was the flash I got , just had it done middle of October, maybe am not being patient enough but would have thought after 2000 mile it would have dropped at least one bar
 
I thought I read somewhere that gm says a tank of def should last for an oil change.

Don't think that is if a person is pulling the whole time.
 
Back
Top